Odd PropBoard Behavior


#1

I recently switched from using 4 AAA batteries (1.5V each) to a single 9V battery. My PropBoard worked fine at first. But now, when I turn it on, the Power On sound plays quietly and choppy. When I strike it, the lights blink continuously for several seconds, instead of just an instant, and there is no sound. After this initial weirdness, the PropBoard behaves normally except that 1) there are no sounds, and 2) I can’t turn it off until I unplug the battery. (The two-second hold down time to turn off the thing no longer has any effect.)

Any idea what’s going on?

I’ve done nothing to the code, but I’ve re-upload it just in case. (Re-uploading solved a problem once before, so I figured it was worth a shot.) No effect.

I also measured the battery voltage when disconnected from the PropBoard: 8.2V. I connected it to the PropBoard and measured the voltage across the battery terminals again: Still 8.2V. Then I measured the voltage at the terminations on the PropBoard: 5.7V. That’s too low to operate the Propboard (I think), which would explain the problem. (Odd freezing blinking behavior happened before when the voltage on my AAA’s dropped too much.) But why the heck is that happening?

One thing to note: Something may have shorted out on the board (:scream::sob:): At some point recently, smoke started rising from it. I don’t know which component it was, and everything looks more or less okay (except for some soldering iron damage, which is to be expected). I can take some photos of the PropBoard and post them if needed.

One other thing to note: One component broke off of the board. (It was sitting very bent on the board, and an attempt to adjust it resulted in it snapping off.) I’m pretty sure I’ve adequately re-soldered both ends in place, but I wanted to mention it just in case. I’ve attached a photo circling this component in red.

If there is directionality to current flow through this piece, that could be a/the source of the problem. Let me know.


#2

Hi @Joecool,

Wow, that’s a lot to analyze, so let start with the basic. The 5.7V when measuring the battery can mean:

  1. a bad battery that drops when the PropBoard needs power.
  2. the wires from the battery to the PropBoard add resistance to the circuit. These would have to be of very bad quality, or stripped at some point to drop almost 3V (but I’ve seen it happening). Try with better/thicker wires.

Try changing one or both of the above mentioned until you see no or little voltage difference between the source (battery) and the PropBoard. I bet on the wires problem.

One question: are you running the PropBoard from the 5.5V-12V range, that is, you didn’t made any modification to make it run on the 3.7V-5V range, correct?


#3

Hi Ivan,

Thanks for the prompt reply! Sorry I didn’t return the favor; been a busy week! Anyway, I’ve tried two different 9V batteries from the same pack of two, so unless the entire pack was bad, I don’t think the battery is an issue.

No, I haven’t made any of those modifications to make the PropBoard run in the lower voltage range.

As for the wires, that’s an interesting thought. I recently added about 4 inches to part of the power line, as I want to add a power cut switch to the circuit to prevent battery drain while off. The added 4 inches coupled with possibly poor quality wires might have something to do with it. I’ll investigate and let you know!


#4

I decided to hook up both my old 4x AAA battery holder and my 9V battery holder, and lo and behold, the thing worked again! So power output is definitely the issue!

The wires that I’ve been using are labeled as 22 gauge (22 awg), so I’m surprised they’re not working for such a low voltage. Perhaps current is the issue? My LEDs draw 1Amp max of current, and I’m not sure how much the speaker or the rest of the Propboard pulls. Does any of that sound fishy to you? What gauge would you recommend?

I mean, I could go all the way up to 18 gauge, but that seems kinda crazy to me. (Plus, I’m not sure that would even fit through the holes in the Propboard!)

EDIT: Found this source that indicates that 22 awg can only handle 0.92Amps (for nick-free soft annealed Cu wire, anyway). That would explain things. Thoughts?


#5

Update:

While power output is the reason for the performance weirdness, it’s not the wires causing the issue. Here’s how I determined this:

I connected the battery to its holder. With the negative wire not connected to the Propboard (the positive wire is still soldered to it, though), I measured the voltage across the battery terminals at 8.2V.

I then measured the voltage at the ends of the wires: still 8.2V. So, the wires aren’t the problem.

Finally, I resoldered the negative wire to the negative power pin on the Propboard, and remeasured the voltage: 5.79V.

I think it has to be a short somewhere in the Propboard. There’s a 0.18V drop across the component that I resoldered into place, so I don’t think that’s the problem. (Though I don’t know what the normal voltage drop should be across that part.)

Any ideas? Would photos of the Propboard help?


#6

Hi @Joecool,

What’s the voltage difference (if any) with the battery pack that works ok?

The diode you’ve re-soldered avoids main power from going back to the power provided from USB, so I don’t think it could be a problem.

Have you tried doing the measurements with LEDs disconnected from the board?


#7

Hi Ivan,

Good idea to try the other battery pack. Looks like with the 4x AAA battery pack, the voltage drops from 5.18V disconnected, to 4.14V connected, and falls fairly rapidly from there by 0.01V about every 2 seconds. Very bizarre!!

I haven’t tried disconnecting the LEDs from the board, as I don’t see how those could be causing the problem. I suppose I could, though. Sounds like you have a hunch. Could you elaborate?

Again, I’d also be happy to post some photos of my progressively-more-toasty board. (Part of my hesitation to remove the LEDs is the continued degradation of the PCB under the heat from the soldering iron.)


#8

Hi @Joecool,

Disconnect the LEDs just if you are seeing these drops while turning them on. LEDs are the most current consuming part in the circuit.

At this point I would load an empty sketch, hook the board up to a fixed, >5.5V stable power supply, remove any other cabling (buttons, etc.) and measure with a multimeter in series to see if there is any strange current drain. In this condition the board shouldn’t go beyond 50mA.

If the current measurement doesn’t show any evident problem, I would repeat the current measurement with a battery pack.

If the current is still OK, I would repeat both tests but with the sketch you are using now.

If you see problems with this sketch, then you can create a new sketch in which you turn on things progressively (audio, motion, LEDs, etc.) while measuring the current consumption to spot where the problem could be coming from.


#9

Thanks, Ivan. The symptoms I’ve described occur when I first connect the batteries to the board. I haven’t even energized the board at that point. So the LEDs are unlikely the source of the problem.

Unfortunately, I don’t have a fixed >5.5V stable power supply that I can readily attach the board to (unless 1) a 9V battery would suffice, or 2) connecting the USB to my PC provides that, which I don’t think it does. Please let me know if I’m mistaken).

Nonetheless, I loaded a new sketch onto the board. The only code present is the following:

void setup() {
// put your setup code here, to run once:

}

void loop() {
// put your main code here, to run repeatedly:

}

I then measured the current by putting my ammeter in series, as you said. I got about 24.5mA. So that’s a good sign! Next, I hooked up my AAA battery pack to the board and measured the voltage. It’s now holding steady at 4.94V! Yay! (Lower than I need, but still: holding steady = progress!)

So, to my great surprise, it appears that the code is the issue. I have no idea how that can be though, as I haven’t modified the code in months: the last Date Modified on the code is February, long before this craziness started. Nonetheless, I reuploaded the code.

Now I got a different weird result: the LED shimmered as it should, but there is no sound, and the ‘hit’ effect is wimpy little light up of the red LED for an instant, rather than the ~0.5 second glow it should be. (And again, no sound.) I also can’t turn the thing back off unless I unplug the battery.

Thinking the current might be too low, I then switched back to my 9V battery (which registers a nice 8.38V). No change. I even tried putting both the AAA battery pack and the 9V battery in parallel to boost the current, but no change.

Urge to kill…rising…

My code is attached. If you want to look through it, please do! But I’m at a loss (for tonight, at least).

sketch_nov24d.ino (9.5 KB)


#10

Hi @Joecool

I still think it’s a battery/cable/power supply problem. This is why:

  1. This is not a code issue! The test with an empty sketch was to pinpoint some abnormal power drain produced by an eventual shortcircuit present while the board is doing nothing. With an empty sketch the amplifier, sensor, SD, LEDs, etc, are all shut off or in stand-by. But this test should be done with a stable power supply.
  1. I reread your posts again, and I started to wonder if you are talking about a regular, off-the-shelf 9V battery. If so, stop using it right now! These kind batteries are not intended to be used in high power applications, where you are (at least) draining 1A from the battery while turning the LEDs on (possibly ~3A with all LEDs on). Will the PropBoard work with a 9V battery? Yes, it will turn on, it may play audio, but these kind of batteries are out of spec.
  1. If with another pack the thing works again then the answer is there. You can use AAA batteries, but I don’t know how much it will last with such power requirements for 1A LEDs.
  1. I don’t think this is a valid test because to measure a drop this way the cables have to be connected to the circuit, otherwise you won’t see the drop with just the multimeter.
  1. Batteries are not ideal voltage supplies! Every kind of battery is different depending on its chemistry, construction, etc. There is so much info about batteries worth to write a book. A lot happens inside the batteries when you start requesting power from them; it depends on the discharge curve, the current you are draining, peaks, and all kind of stuff. If I have to recommend a battery, I will say to use a LiPo (as I believe it’s in the PropBoard manual). The USB power is not enough to fully use the PropBoard: for example with just USB power the LEDs won’t work.

  2. Finally, what you describe (crappy audio, LEDs not doing what they are supposed to do) can be explained with a battery or power supply problem. It will be easier to reason over other things when that’s cleared out of the equation.

So if you want to check if there is something wrong with the PropBoard (shortcircuits, broken components, etc.), I suggest to first discard power supplies issues (being it cables or batteries) by using a good and stable power supply. If you believe there is something with the software you wrote/modified, the you can upload the original example. At the moment there are too many variables in place to clearly diagnose a hardware problem.


#11

Thanks, Ivan. I appreciate the battery clarification! I had indeed been using a standard, off-the-shelf 9V battery. I didn’t consider the discharge requirements, only the voltage requirements. Is there a chance I’ve damaged the board as a result? (I hope not!)

What you’re saying about the power supply being the problem makes a lot of sense, since I saw wonky behavior several months ago when the AAA batteries I was using started being depleted. (Well, they still had the majority of their charge, but my circuit required such high power, that it didn’t function properly after only a little use of the AAA batteries.)

Thanks for the recommendations on a LiPo battery. Would a couple of these work? They are 18650 batteries, as described by the manual.

PS
Looking at the manual, the following is stated (6th bullet point in the Introduction section):

You can use any battery as long as they provide voltage within the power supply range

I suggest you either strike this sentence or revise it to avoid a repeat of my problem with other users. I’m certainly don’t blame you or anyone else other than myself for my mistake! I just figure clarifying this statement might help avoid a repeat of the problem in the future.

Thanks again, Ivan. Your advice is invaluable. I really, really appreciate it!


#12

Hi @Joecool,

Yes, that battery seems OK.

And yes, that sentence from the manual should be modified, maybe with some links to a couple of battery examples.


#13

Thanks, Ivan. I went out and bought that battery, only to discover that it’s far larger than a AA or AAA, and the two I’d need won’t fit in my lightsaber along with the other components. I have two options at this point:

  1. I could ask here if there’s some other battery option available that’s more compact.
  2. I could completely overhaul the internal design of my lightsaber.

Obviously, I’d like to start with option #1. I was hoping a 9V battery would do the trick, but as you mentioned, I guess that doesn’t provide a high enough power output. Do you have any other battery recommendations?


#14

Hi @Joecool

You can find Li-ion batteries in 14500 format (that’s AA measure) instead of 18650. Can’t find any website right now able to produce a decent datasheet. If you find one, check if the max. current drain is within the typical current consumption of your circuit (beyond 2A?).

Note also that their voltage is 3.7V and if you use 4 of them with the PropBoard you’ll be over the maximum voltage supported.


#15

That’s great news!! I was starting to think I would have to basically start over.

I’m not sure what my current draw is. (This is my LED. When the lightsaber hit effect activates, I’m guessing I pull maybe a little over 2A for a bit?? Maybe that’s my problem…) However, my circuit initially worked when I used 4 brand new Energizer E92 AAA batteries.

If I were to go strictly off of voltage (which I now know isn’t proper):
AAA battery = 1.5V. Thus, 4 x 1.5V = 6V
14500 battery = 3.7V. Thus, 2 x 3.7V = 7.4V (> 6V)
Therefore, I’d only need two 14500 batteries.

Taking into account current draw:
Let’s assume I’m drawing 2 Amps. I’d need 4 AAA batteries, each discharging 500mA to reach that current. According to the capacity-discharge chart (if I’m reading it right), this means a per-battery capacity of about 450mAh. Thus:
450mAh / 500mA = 0.9 hours.
No wonder my circuit eats AAA batteries like crazy, and I’m getting odd behavior after using it for a while!
(How’d I do with this calculation?)

I’ve found one 14500 battery available at a local store, and here’s the manufacturer’s webpage with the datasheet. (Version LS 14500.) However, it looks like that battery is rated for only up to 100mA of current draw. Am I reading it correctly?


#16

Hi @Joecool

That’s a lithium-thionyl chloride (Li-SOCl2) with a 250mA max (pulsed) current drain. You need a Lithium-Polymer (LiPo) or Lithium-Ion (Li-ion) battery.


#17

Ah, of course. Thanks.

I’m having a difficult time finding Li-Ion datasheets, as well. But I did find this. Would any of them be suitable? PH5 (which I can buy here) looks pretty encouraging to me.


#18

It’s the first time I see a 1.5V Li-ion battery. You may need some special charger for these, I believe.
Worth a try for sure.


#19

Hmm. I was hoping for more of a sure bet. Have you found anything that will for sure work?


#20

I’ve found Energizer Ultimate Lithium AAA batteries:
http://www.energizer.com/batteries/energizer-ultimate-lithium-batteries#aaa

I’m a bit skeptical, since they’re pretty typical off-the-shelf batteries. But they are 1.5V and the datasheet says the max current draw is 1.5Amps per battery. So, if I use 4 of them, I should have no problem, right? (The battery might just not last that long. But as a stop gap, it would be okay?)