Problems with sound and on/off button


#21

Hi @dadoo, perhaps the coil is open due to a shortcircuit.

Please remove the component from the picture and replace it with drop of solder (join the pads).


#22

I did not remove the component but I redo the test and
I get this values:

3.3V to point 1
3.3V to point 2
0V to point 3
but i did not have an oscilloscope.

Finaly what’s news is now the board is not recognized by the arduino IDE.
and now nothing works. the board is powered cause i got value just above.

Do you think the board is dead ?


#23

Does Arduino IDE say that it can’t open the serial port or it goes into timeout when downloading a sketch?


#24

Arduino IDE started by timeout and now it can’t open a serial port


#25

Ok @Dadoo, I think it’s better to inspect your board here. I will contact you by email to arrange return and replacement.


#26

I just got my replacement board, I will put it together over the weekend.


#27

Great. I suggest you however to do a test with the sketch here above by just connecting the USB cable and before connecting anything else, just to check if there is still problem with the SD, even if you can’t hear the audio.

Thank you.


#28

uggghhh I finally had time to finish getting all my stuff together and it still says problem reading. I’m having the same problem. I tried all my microSDs. So either both boards are bad, all my SDs are bad, or I majorly messed something up. Twice.


#29

I see.

We fully test all the boards before shipping. Yours I tested it personally, so I doubt it could be a production defect.

I still think there should be something with those SD. Today we should receive your part no. SD cards so I can run a test here.

In the meantime let me check if I can pull the modifications for the SD module from the new version of the software and send it to you. There are some debug messages there that I can use to diagnose the problem.

By the way, did you tested it before connecting your hardware (LEDs/speaker/button)? Just by plugging the USB cable and running the above sketch, as per this suggestion?


#30

I didn’t see that until I’d plugged everything in for some reason, but I made it all removable and unplugged all the wires and it still said problem reading.


#31

Hi @mathtapmusic,

Please try the following. Rename thesdcard.cpp and sdcard.h files in the C:\Users\MyUser\AppData\Local\Arduino15\packages\artekit\hardware\stm32f4\1.0.1\cores\propboard folder (where MyUser is your Windows user name). Rename them like sdcard.cpp.old and sdcard.h.old. Then copy into that folder the following two attached files.

sdcard.h (7.0 KB)
sdcard.cpp (42.4 KB)

Then copy idle1.wav to the SD and execute the following sketch and paste here in the forum what is output to the Serial Console.

WavPlayer myPlayer;

void setup() {
  // put your setup code here, to run once:
  Audio.begin();
  Serial.begin(9600);
  enableSdDebug(&Serial1);

  if (myPlayer.play("idle1.wav", PlayModeLoop))
  {
    Serial.println("Playing");
  } else {
    Serial.println("Problem reading");
  }
}

void loop() {
  // put your main code here, to run repeatedly:
}

By the way, we have received the SD you are using.


They worked fine.


Arduino SD library
#32

Oh… I found it… I stupidly misnamed all my sound files with “.wav” in the actual name -_- I had them in a folder on one of the cards and thought oh, I should move them out to make sure it works, and then I realized .wav didn’t need to be in the names. Good news is, that also seems to have gotten rid of the problem with not being able to turn the board off! Now I can experiment with my RGBs :smiley: I’m sorry I screwed that up…


#33

Hi @mathtapmusic,

No worries, I’m glad you got it sorted out! :grinning: