USB and Serial Port Connections


I just finished soldering my peripherals to my Propboard, downloaded and installed the Arduino IDE, and wrote my code. I was all set to upload the code to the board only to find that I need a serial port on my PC! According to the website, I need a USB-to-serial connection in order to upload the code!

I could go out and buy a usb-to-rs232 adapter, install the adapter’s driver to my PC to create a sort of virtual COM port, then buy a usb-to-serial adapter cable and connect to that, but that seems extremely silly; my cable setup would be usb-serial-usb!

Is there a way for me to upload my code directly to the Propboard using only a usb connection?


You don’t need a serial port on your PC. The usb-to-rs232 adapter is already included and mounted on the board (what is called “the FTDI chip”). You only need an USB cable.

The virtual COM port is created when you connect the PropBoard using the USB cable. Depending on your OS you will need drivers, but if you are using WIN7 and up, or a modern Linux distro, the drivers should be already included or can be downloaded automatically (i.e. Windows Update).

If you already connected the USB cable and it’s not generating the virtual COM port, check your connections and see if there is a shortcircuit preventing the FTDI to work. Also check that you are not using a “power only” USB cable (like those that come with battery chargers, that do not have the data lines).

Thanks for the quick reply, Ivan!

I was about to write a longer explanation of the problem, but after you mentioned trying a different USB cable, I tried another version of the one I use to charge my phone. (Both cables can definitely transfer data as well as power the thing. But the one I was using was starting to flake out on me, so I bought a new one.) After waiting a minute, that did the trick: A new COM port appeared on the Arduino IDE drop-down menu! Woohoo!


Hi folks,

Having tried resolving a similar issue, I am reaching to the Forum for some input. The Propboard doesn’t show up in the Arduino Ports list.

This is what I did on my Mac (10.14.6) after following all the Artekit guide.
I connected via USB, then checked the Proboard was detected by the computer by hitting this on Terminal:

ioreg -p IOUSB -w0
And I saw that the Propboard was detected (named “ FT231X USB UART@14200000 ” ).

I even installed the “Virtual COM port (VCP) driver” and rebooted, and tried a different USB cable (which also detected the Propboard).

But it still doesn’t show up in the " Tools > Port: " list…

Neither my brains nor my Google-Fu have other options in mind.

Anybody got some fuzz? :thinking:


EDIT: Although I had already rebooted, I did another reboot later on, and now the Propboard has appeared in the Ports list. I managed to upload the Software.

2EDIT: I understood why it ended-up working: the solution is to boot with the USB cable connected already. Then when opening the Tools > Port menu in the the Propboard shows-up in the list.
This is mentioned in this post sent by @Ivan (thank you): Stackoverflow - Arduino FTDI on Mac

Hello @g.delajoux,

Unfortunately we don’t have a Mac to test the current state of the OS and compatibility. We do know that FTDI (the manufacturers of the chip that makes the PropBoard to communicate through USB) deliver drivers for all platforms including Mac.

Searching online there are other users with similar problems. For example:

A Google search for “ftdi arduino serial port mac” comes up with other similar cases too.

You can try those proposed solutions. Also, if you have another kind of board that happens to have an FTDI chip, you can try that board too to discard any problems with your combination of OS and FTDI drivers.

1 Like

Thank you very much for the quick support!! I’m new to this, but proceeding at my pace and it’s getting better :slight_smile: